Audio en FreeBSD

Un problema bastante común durante la configuración de la tarjeta de audio en FreeBSd es saber realmente que modulo se debe cargar.

Si se lee el HandBook el proceso es claro pero cargar el modulo no tanto.

Existe un simple script que tras ser ejecutado te dice que modulo debes cargar

[sourcecode language=»bash»]
#!/bin/sh

# Copyright (c) 2004, Romain TARTIERE <romain-tartiere@astase.com>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions
# are met:
# 1. Redistributions of source code must retain the above copyright
# notice unmodified, this list of conditions, and the following
# disclaimer.
# 2. Redistributions in binary form must reproduce the above copyright
# notice, this list of conditions and the following disclaimer in the
# documentation and/or other materials provided with the distribution.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR «AS IS» AND ANY EXPRESS OR
# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
# OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
# IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
# NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# Root ?
expr `id -u` = 0 > /dev/null || {
echo "Error: This utility should only be run as root."
exit 1
}

# Any driver loaded ?
kldstat | grep ‘snd_*’ > /dev/null 2>&1 && {
echo "Error: No sound driver should be loaded."
exit 1
}

cd /boot/kernel

Result=»; # Drivers that do something
Cnt=`ls snd_* | wc -l` # Drivers count

echo -n ‘[Trying sound drivers -‘ $Cnt ‘drivers found ‘
for i in snd_*
do
echo -n ‘.’
kldload $i
[ -e /dev/audio0.0 ] && Result="$Result $i"
kldunload $i
done
echo ‘ done]’

# Print result
echo "===> Usable sound driver(s) : $Result"

# That’s all folks !

[/sourcecode]

En mi caso en IBM NetVista el resultado es

[sourcecode language=»bash»]
unix# ./audio.sh [Trying sound drivers – 25 drivers found ……………………. done] ===>
Usable sound driver(s) : snd_driver.ko snd_maestro3.ko unix#
[/sourcecode]

El siguiente paso es fácil, se edita el fichero /boot/loader.conf y se añade las siguientes lineas

[sourcecode language=»bash»]
sound_load="YES"
snd_maestro3_load="YES"
[/sourcecode]

Un comentario

Comments are closed.

Google+